您的位置:首页 > 其它

NYOJ 5 Binary String Matching

2013-12-17 18:49 357 查看



[title2]
Binary String Matching[/title2]

时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the
pattern A appeared at the posit

输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer
than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


/*串的匹配算法,没必要用经典的KMP,BM算法*/

#include <stdio.h>
#include <string.h>

int main()
{
int N,len,total;
char sub[11];
char str[1001];
char *p;
scanf("%d",&N);
while (N--)
{
scanf("%s",sub);
scanf("%s",str);
total = 0;
p = str;
len = strlen(sub);
while (*p != '\0')
{
if (strncmp(p,sub,len) == 0)
{//如果匹配,则总数加1
total++;
}
++p;
while (*p != *sub && *p != '\0')
{//将指针p移动到与子串第一个字符相等的地方
++p;
}
}
printf("%d\n",total);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: