您的位置:首页 > 其它

并查集-杭电1856-More is better-难度1

2013-12-16 22:23 267 查看
Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 

Sample Output

4
2

题目要求: 求最大连通分量。

代码:

#include <iostream>
using namespace std;

const int MAX = 10000001;
int boy[MAX];
int friends[MAX];

int findRoot(int x)
{
if(boy[x] == -1)
return x;//如果x是根节点,则返回x
else
{
boy[x] = findRoot(boy[x]);//如果x不是根节点,则查找x上一个节点的根节点
//并且把x的上一节点赋值为根节点
return boy[x];// 一定要返回根节点
}
}
int main()
{
//freopen("F:\\input.txt", "r", stdin);
//freopen("F:\\output.txt", "w", stdout);
int  M;//M 表示朋友对数
while(cin >> M)
{
for(int i = 1; i < MAX; i++)
{
boy[i] = -1;
friends[i] = 1;
}
for(int i = 0; i != M; ++i )
{
int a, b;// a,b 表示输入的两个节点
cin >> a >> b;
int x, y;
x = findRoot(a);
y = findRoot(b);// x, y分别表示a,b的根节点
if(x != y)
{
boy[x] = y;
friends[y] = friends[y] + friends[x];//把根节点x下的节点加到根节点y下
}
}
int max = 0;//max表示朋友最多集的朋友个数
for(int i = 1; i < MAX; i++)
{
if(friends[i] > max)
max = friends[i];
}
cout << max << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: