您的位置:首页 > 其它

HDU 2602 Bone Collector

2013-12-15 23:02 357 查看



Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 23264 Accepted Submission(s): 9443



Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1


Sample Output

14


Author

Teddy

Source

HDU 1st “Vegetable-Birds
Cup” Programming Open Contest

Recommend

lcy | We have carefully selected several similar problems for you: 1203 2159 2955 1171 2191

典型的01背包题目,说实话我是看了别人的算法模板的,还不是很理解,明天接着刷类似的题目吧,期待会有所领会。
代码如下:
#include <stdio.h>
#include <string.h>
#define rep(i,k,n) for(int i=(k); i<(n); i++)
#define cls(x,a) memset(x,a,sizeof(x))
#define maxn 10010

int a[maxn],b[maxn];

int main(void){
int n,m,t;
int dp[maxn];
scanf("%d",&t);
rep(i,0,t){
scanf("%d%d",&n,&m);
rep(i,0,n) scanf("%d",&a[i]);
rep(i,0,n) scanf("%d",&b[i]);
cls(dp,0);
rep(i,0,n)
for(int j=m; j>=b[i]; j--){
if (dp[j]<dp[j-b[i]]+a[i])
dp[j] = dp[j-b[i]]+a[i];
}
printf("%d\n",dp[m]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: