您的位置:首页 > 其它

POJ 1651区间DP

2013-12-14 12:27 288 查看
Multiplication Puzzle

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5442Accepted: 3286
Description
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number
on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5

Sample Output
3650

Source
Northeastern Europe 2001, Far-Eastern Subregion

相当于矩阵连乘,很基础的一个区间DP。。
/****************************************************
* author:crazy_石头
* Pro:POJ 1651
* algorithm:区间DP
* Time:32ms
* Judge Status:Accepted
*******************************************************/
#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>

using namespace std;

#define rep(i,h,n) for(int i=(h);i<=(n);i++)
#define ms(a,b) memset((a),(b),sizeof(a))
#define eps 1e-8
#define INF 1<<29
#define LL __int64
const int maxn=100+5;

int a[maxn];
int dp[maxn][maxn];

inline int dfs(int l, int r)
{
	if (dp[l][r]!=0) return dp[l][r];
	if (r==1+l) return 0;
	if (r==2+l) return dp[l][r]=a[l]*a[l+1]*a[r];
	int ans=INF;
	rep(i,l+1,r-1)
		ans=min(ans,dfs(l,i)+dfs(i,r)+a[l]*a[i]*a[r]);
	return dp[l][r]=ans;
}

int main()
{
	int n;
	scanf("%d",&n);
	rep(i,0,n-1)
		scanf("%d", &a[i]);
	printf("%d\n", dfs(0,n-1));
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: