您的位置:首页 > 其它

动态规划 hdu 1260 Tickets

2013-12-13 22:32 330 查看
Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering
when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets
at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home
as early as possible? If so, I guess Joe would full of appreciation for your help.
 
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
2
2
20 25
40
1
8
 

Sample Output
08:00:40 am
08:00:08 am
 
Solution

难点是输出。

#include <iostream>
using namespace std;
#define min(a,b) (a)<(b)?(a):(b)
#define MAX 2001
int N,n,k,i,a[MAX],b[MAX],f[MAX];
int h,m;
bool am;
int main()
{
cin>>N;
for (n=1;n<=N;n++)
{
cin>>k;
for (i=1;i<=k;i++)
cin>>a[i];
for (i=1;i<=k-1;i++)
cin>>b[i];
f[0]=0;f[1]=a[1];
for (i=2;i<=k;i++)
f[i]=min(f[i-2]+b[i-1],f[i-1]+a[i]);
h=8+f[k]/3600;
f[k]%=3600;
m=f[k]/60;
f[k]%=60;
am=h<12;
if (h<10)
{
cout<<'0'<<h<<':';
am=true;
}
else if (h<12)
{
cout<<h<<':';
am=true;
}
else if (h==12)
{
cout<<h<<':';
am=false;
}
else if (h<22)
{
cout<<'0'<<h-12<<':';
am=false;
}
else
{
cout<<h-12<<':';
am=false;
}
if (m<10)
cout<<'0'<<m<<':';
else
cout<<m<<':';
if (f[k]<10)
cout<<'0'<<f[k];
else
cout<<f[k];
if (am)
cout<<" am"<<endl;
else
cout<<" pm"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息