您的位置:首页 > 其它

Palindromic Squares

2013-12-11 21:48 302 查看
Palindromic Squares

Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.
Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square.
Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.
Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696


/*
ID:qhn9992
PROG:palsquare
LANG:C++
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>

using namespace std;

int base;
char str[1000],show[1000];

char idx(int x)
{
if(x>=0&&x<=9) return x+'0';
else return x-10+'A';
}

void change(int x)
{
int e=base,cnt=0;
while(x)
{
int t=x%e;
x/=e;
str[cnt++]=idx(t);
}
str[cnt]=0;
}

void Show(int x)
{
int e=base,cnt=0;
while(x)
{
int t=x%e;
x/=e;
show[cnt++]=idx(t);
}
show[cnt]=0;
for(int i=0,j=cnt-1;i<j;i++,j--)
{
swap(show[i],show[j]);
}
}

bool ck()
{
int t=strlen(str);
for(int i=0,j=t-1;i<j;j--,i++)
{
if(str[i]!=str[j]) return false;
}
return true;
}

int main()
{
freopen("palsquare.in","r",stdin);
freopen("palsquare.out","w",stdout);
cin>>base;
for(int i=1;i<=300;i++)
{
change(i*i);
if(ck())
{
Show(i);
cout<<show<<" "<<str<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  USACO