您的位置:首页 > 其它

poj1125 POJ 1125 Stockbroker Grapevine(两种方法Dijkstra或者floyd)

2013-12-10 18:43 381 查看
Stockbroker Grapevine

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 24440Accepted: 13443
Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect,
you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact
with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each
pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person,
measured in integer minutes.

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output
3 2
3 10

题目大一(相当的难懂):[code]首先,题目可能有多组测试数据,每个测试数据的第一行为经纪人数量N(当N=0时,输入数据结束),然后接下来N行描述第i(1<=i<=N)个经纪人与其他经纪人的关系
(教你如何画图)。每行开头数字M为该行对应的经纪人有多少个经纪人朋友(该节点的出度,可以为0),然后紧接着M对整数,每对整数表示成a,b,则表明该经纪人向第a
个经纪人传递信息需要b单位时间(即第i号结点到第a号结点的孤长为b),整张图为有向图,即弧Vij 可能不等于弧Vji(数据很明显,这里是废话)。
当构图完毕后,求当从该图中某点出发,将“消息”传播到整个经纪人网络的最小时间,输出这个经纪人号和最小时间。
最小时间的判定方式为——从这个经纪人(结点)出发,整个经纪人网络中最后一个人接到消息的时间。
如果有一个或一个以上经纪人无论如何无法收到消息,输出“disjoint”(有关图的连通性,你们懂得,但据其他同学说,POJ测试数据中不会有,
就是说,你不判定,一样能过,题目数据够水的)。

思路:由于“将“消息”传播到整个经纪人网络的最小时间”是按最玩的那个人收到的时间,所以可以转化为,以每个i点位源点作单源路径,
记d[i]为求源点i到其他点的距离的最大值,
求min(d[i]),和i,其中1<=i<=n;

方法一:依照思路很容想到对每个节点用一次单源最短路算法,所有源点中所到其他点的其最大值的最小值,时间复杂度为O(n^3);
/*
@author : liuwen
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int maxn=105;
const int inf=0x5fffffff;
int Map[maxn][maxn],dist[maxn],p[maxn];
int n,m;
void initial_map() //初始化图,用邻接矩阵建图,空间复杂度为O(n^2)
{
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(i==j) Map[i][j]=0;
else Map[i][j]=inf;
}
}
for(int i=1;i<=n;i++){
int t,v,w;
scanf("%d",&t);
while(t--){
scanf("%d%d",&v,&w);
Map[i][v]=min(Map[i][v],w);
}
}
}
void Dijkstra(int s) //以s为源点的单源最短路
{
memset(p,0,sizeof(p));
for(int i=1;i<=n;i++){
dist[i]=Map[s][i];
}
dist[s]=0;
p[s]=1;
int i,j,k,Min;
for(i=1;i<=n-1;i++){
Min=inf,k=0;
for(j=1;j<=n;j++){
if(!p[j]&&Min>dist[j]){ //我艹,把符号写反了,3wa
Min=dist[j];
k=j;
}
}
if(k==0) return; //如果Vb(还没有选择的点集合中)中点都不可到达,则可以直接退出
p[k]=1;
for(j=1;j<=n;j++){ //松弛操作,更新
if(!p[j]&&Map[k][j]!=inf&&dist[j]>dist[k]+Map[k][j]){
dist[j]=dist[k]+Map[k][j];
}
}
}
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d",&n)==1){
if(n==0) break;
initial_map();
int maxLength=-inf,minTrans=inf,fastTrans=1;
for(int i=1;i<=n;i++){
maxLength=-inf;
Dijkstra(i); //以每个节点为源点的单源最短路
for(int j=1;j<=n;j++){
if(dist[j]>maxLength){
maxLength=dist[j];
}
}
if(maxLength<minTrans){
fastTrans=i;
minTrans=maxLength;
}
}
if(minTrans==inf){ //不可以达到
printf("disjoint\n");
}else{
printf("%d %d\n",fastTrans,minTrans);
}
}
return 0;
}[/code]第二种方法:floly多源路径的最短路问题,复杂度为O(n^3)
floyd原理说明
其思想为动态规划的思想:
<i,j>的最短距离 =min{ <i,j>的距离,<i,k>+<k,j>(经过一个中间点)距离和}
即:Map[i][j]=min(Map[i][j],Map[i][k]+Map[k][j]);
/*
@author : liuwen
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int maxn=105;
const int inf=0x1fffffff;    //一开始inf开的太大,Map[i][j]=min(Map[i][j],Map[i][k]+Map[k][j]);算加法的时候溢出了T_T
int Map[maxn][maxn],n;
void initial_map()
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++){
if(i==j)    Map[i][j]=0;
else    Map[i][j]=inf;
}
}
for(int i=1;i<=n;i++){
int t,v,w;
scanf("%d",&t);
while(t--){
scanf("%d%d",&v,&w);
Map[i][v]=min(Map[i][v],w);
}
}
}
void floyd()
{
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
Map[i][j]=min(Map[i][j],Map[i][k]+Map[k][j]);//一开始inf开的太大,"Map[i][k]+Map[k][j]"加法溢出T_T,的了变成负数。。样例都没过。
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d",&n)==1){
if(n==0)    break;
initial_map();
floyd();
int fastTrans=1,maxlength=-inf,minTrans=inf;
for(int i=1;i<=n;i++){
maxlength=-inf;
for(int j=1;j<=n;j++){
maxlength=max(maxlength,Map[i][j]);
}
if(maxlength<minTrans){
minTrans=maxlength;
fastTrans=i;
}
}
if(minTrans==inf)   printf("disjoint\n");
else                printf("%d %d\n",fastTrans,minTrans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: