您的位置:首页 > 其它

hdu 2594 Simpsons’ Hidden Talents(KMP)

2013-12-05 23:10 441 查看


Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2181 Accepted Submission(s): 818



Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie


Sample Output

0
rie 3


Source

HDU 2010-05 Programming Contest

题意:找前一个字符串的前缀和后一个字符串的后缀一样的最长长度

题解:KMP的简单应用,无聊复习一下KMP

#include<stdio.h>
#include<string.h>
char str1[50005],str2[50005];
int next[50005];
void get_next()
{
int len=strlen(str1),i,j;

next[0]=j=-1;
for(i=0;i<len;)
{
if(j==-1||str1[i]==str1[j]) next[++i]=++j;
else j=next[j];
}
}
int solve()
{
int len1=strlen(str1),len2=strlen(str2);
int i,j=0;

for(i=0;i<len2;)
{
if(j==-1||str2[i]==str1[j])
{
j++,i++;
if(j==len1&&i!=len2) j=next[j];
}
else j=next[j];
}

return j;
}
int main()
{
int res;

while(gets(str1)>0)
{
gets(str2);
if(str1[0]=='\0'&&str2[0]=='\0')
{
printf("0\n");
continue;
}
get_next();
res=solve();
str1[res]='\0';
if(res) printf("%s %d\n",str1,res);
else printf("0\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: