您的位置:首页 > 其它

hdu4763(kmp水题)

2013-12-05 21:04 253 查看
地址:http://acm.hdu.edu.cn/showproblem.php?pid=4763


Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the
rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where
section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

 

Input

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

 

Output

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

 

Sample Input

5
xy
abc
aaa
aaaaba
aaxoaaaaa

 

Sample Output

0
0
1
1
2

 

题意:找最长相同前后缀,并且字符串中间(不包括前后缀)也要有该子串。

思路:暴力,用kmp稍微剩下时间。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char s[1000010];
int next[1000010],len;
void getnext()
{
int i=0,j=-1;
next[0]=-1;
while(i<len)  //以前在这里是调用strlen()函数来判断,TLE无数次
{
if(j==-1||s[i]==s[j])
{
i++;j++;
next[i]=j;
}
else j=next[j];
}
}
int main()
{
int t,k,ans;
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
len=strlen(s);
getnext();
k=next[len];ans=0;
while(k&&!ans)
{
int g=0;
for(int i=k;i<len-k;i++)
{
if(g==k) break;
while(!(g==-1||s[i]==s[g]))
g=next[g];
g++;
}
if(g==k) ans=k;
k=next[k];
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu kmp