您的位置:首页 > 其它

poj 1007 DNA sorting

2013-12-05 10:43 369 查看
DNA Sorting

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 77160Accepted: 30918
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


大致题意:给定长度为n,m个字符串,根据字母表顺序,来比较每个字符串的逆序数,根据逆序数从小到大输出

排好序的字符串,如果有些字符串逆序数相同,按照以前给定字符串的顺序输出。

poj的数据可能有问题,我用sort竟然也过了。

解题思路:其实就是求逆序数并进行字符串排序,关键点在于如何排序,如果逆第一时间想到sort或者qsort,

那么恭喜你打错了,题目要求按原给定顺序输出,实际就是稳定排序,可以使用冒泡或者STL的stable_sort()

进行排序,两者都是稳定排序。

看到网上介绍几种排序:引用网址:稳定排序和不稳定排序

1.稳定的:冒泡,插入,归并,基数。

2不稳定的:快速,选择,希尔,堆排序。

#include <stdio.h>
#include <algorithm>
using namespace std;

struct Node
{
    char str[52];
    int count;
};

bool mycmp(Node a, Node b)
{
	return a.count < b.count;
}

Node dna[102];

int getRev(char s[], int n)
{
    int i, j, cnt = 0, tmp;
    for (i=0; i<n-1; ++i)
    {
        tmp = 0;
        for (j=i+1; j<n; ++j)
        {
            if (s[i] > s[j])
                tmp++;
        }
        cnt += tmp;
    }
    return cnt;
}

int main()
{
    int n, m, i, j;
    Node t;
    scanf("%d %d", &n, &m);
    for (i=0; i<m; ++i)
    {
        scanf("%s", dna[i].str);
        dna[i].count = getRev(dna[i].str, n);
    }
    
/*	
	// 冒泡排序也是稳定排序
	for (i=0; i<m; ++i)
    {
        for (j=0; j<m-i-1; ++j)
        {
            if (dna[j].count > dna[j+1].count)
            {
                t = dna[j];
                dna[j] = dna[j+1];
                dna[j+1] = t;
            }
        }
    }
*/
    stable_sort(dna, dna+m, mycmp);	// STL stabel_sort(first, end ,cmpfunc) 稳定排序
    for (i=0; i<m; ++i)
        puts(dna[i].str);

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: