您的位置:首页 > 其它

pku3517(约瑟夫环)

2013-12-01 13:34 260 查看
 
And Then There Was One

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4469 Accepted: 2366
Description

Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbersk and
m. From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stonem. In step 2, locate the
k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, makek hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k
− 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case
n = 8, k = 5, m = 3 is 1, as shown in Figure 1.



Initial state


Step 1


Step 2


Step 3


Step 4


Step 5


Step 6


Step 7


Final state
 
Figure 1: An example game
Initial state: Eight stones are arranged on a circle.
Step 1: Stone 3 is removed sincem = 3.
Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (sincek = 5), and remove the next one, which is 8.
Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.
Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped
twice in step 7.
Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.

Input

The input consists of multiple datasets each of which is formatted as follows.

n k m
The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤
m ≤ n
The number of datasets is less than 100.

Output

For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.

Sample Input
8 5 3
100 9999 98
10000 10000 10000
0 0 0

Sample Output
1
93
2019

Source
Japan 2007
 
       本题给定开始位置m,从该处开始报数,每到k就删除该数,是个约瑟夫环的变种。在n-1个数中运用约瑟夫环基本解法,然后加上第m个数。
#include<iostream>
using namespace std;

int n,k,m;

int Joseph()
{
int ret=0,i=2;
while(i<=n)
{
ret=(ret+k)%i;
i++;
}
return ret+1;
}

int main()
{
int ans;
while(~scanf("%d%d%d",&n,&k,&m))
{
if(!n&&!m&&!k)break;
n--;
ans=Joseph();
ans=(ans+m)%(n+1);
if(!ans)ans=(n+1);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学