您的位置:首页 > 其它

poj 3169 Layout (差分约束)

2013-12-01 12:09 423 查看
Layout

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5955Accepted: 2842
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source

USACO 2005 December Gold

//Accepted    328K    79MS    C++    1466B    2013-12-01 12:01:47
/*

题意:
有n个点,接着ml行数据,表示a-b<=d,接着md行数据,表示a-b>=d
求点1到点n的最长距离,无限远输出-2,不存在输出-1

差分约束:
对差分约束有一定的了解了,不过最大的问题还是在构图上,因为构图错了好几次。

因此在此再次分析构图的情况:
差分约束的构图有两种情况:

a-b>=c 的形式要求最短路

a-b<=c的模式要求最长路

此题要求最长路,但亦可转化为求最短路,因为有负环的存在,要求
使用的算法为bellman_ford或spfa。

*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<vector>
#define N 1005
#define inf 0x7ffffff
using namespace std;
struct node{
int v,w;
node(int a,int b){
v=a;w=b;
}
};
vector<node>V
;
int d
,in
;
int vis
;
int n,ml,md;
bool spfa()
{
for(int i=0;i<=n;i++) d[i]=inf;
memset(vis,0,sizeof(vis));
memset(in,0,sizeof(in));
queue<int>Q;
Q.push(1);
d[1]=0;
in[1]=1;
while(!Q.empty()){
int u=Q.front();
Q.pop();
if(in[u]>n) return false;
vis[u]=0;
int n0=V[u].size();
for(int i=0;i<n0;i++){
int v=V[u][i].v;
int w=V[u][i].w;
if(d[u]!=inf && d[v]>d[u]+w){
d[v]=d[u]+w;
in[v]++;
if(!vis[v]){
Q.push(v);
vis[v]=1;
}
}
}
}
return true;
}
int main(void)
{
int a,b,c;
while(scanf("%d%d%d",&n,&ml,&md)!=EOF)
{
for(int i=0;i<ml;i++){
scanf("%d%d%d",&a,&b,&c);
V[a].push_back(node(b,c));
}
for(int i=0;i<md;i++){
scanf("%d%d%d",&a,&b,&c);
V[b].push_back(node(a,-c));
}
if(spfa()){
if(d
==inf) puts("-2");
else printf("%d\n",d
);
}else puts("-1");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: