您的位置:首页 > 其它

高精度乘法

2013-11-29 19:49 295 查看

a*b
Time Limit: 1sec Memory Limit:32MBDescriptionGive two positive integers a and b, please help us calculate a*b.
InputThe first line of the input is a positive integer T. T is the number of test cases followed.
Each test case contain two integer a,b (0<=a<=10^100, 0<=b<=10,000) given in one line.
OutputThe output of each test case should consist of one line, contain the result of a*b.
Sample Input Copy sample input to clipboard
12 7


Sample Output

14


a为一个大数 ,b为一个int数
所以a需要用字符串表示,b用int表示即可
#include <iostream>
#include <cstring>
#include <memory>
using namespace std;
int main() {
int T;
cin >> T;
while(T--) {
string a;
int b;
cin >> a >> b;
int num[101];
int result[120];
// cout <<a<<endl;
int alength = a.length();
// cout << "alen" << alength <<endl;
memset(result,0,sizeof(result));
for(int i = 0;i < alength;i ++) {
num[alength - i - 1] = a[i] - '0';
// cout <<"dd:"<< a[i];
}

int carry = 0;
for(int i = 0;i < alength;i ++) {
result[i] = num[i] * b + carry;
carry  = result[i]/10;
result[i] %= 10;

}
result[alength] = carry;
int resultlen = alength + 6;
while(result[resultlen]==0 && resultlen >= 0) {
resultlen --;
}
//cout << resultlen << endl;
if(resultlen < 0)
cout << "0" << endl;
else {
for(int i = resultlen;i >= 0;i --) {
cout << result[i];
}
cout << endl;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: