您的位置:首页 > 编程语言 > Java开发

第五届河南省程序设计大赛nyoj545Metric Matrice(java 类goto语句)

2013-11-29 14:07 519 查看

Metric Matrice

时间限制:1000 ms  |  内存限制:65535 KB

难度:1

描述
Given as input a square distance matrix, where a[i][j] is the distance between point i and point j, determine if the distance matrix is "a  metric" or not.

A distance matrix a[i][j] is a metric if and only if

    1.  a[i][i] = 0

    2, a[i][j]> 0  if i != j

    3.  a[i][j] = a[j][i]

    4.  a[i][j] + a[j][k] >= a[i][k]  i ¹ j ¹ k

输入The first line of input gives a single integer, 1 ≤ N ≤ 5, the number of test cases. Then follow, for each test case,

* Line 1: One integer, N, the rows and number of columns, 2 <= N <= 30

* Line 2..N+1: N lines, each with N space-separated integers

(-32000 <=each integer <= 32000).输出Output for each test case , a single line with a single digit, which is the lowest digit of the possible facts on this list:

* 0: The matrix is a metric

* 1: The matrix is not a metric, it violates rule 1 above

* 2: The matrix is not a metric, it violates rule 2 above

* 3: The matrix is not a metric, it violates rule 3 above

* 4: The matrix is not a metric, it violates rule 4 above
样例输入
240 1 2 31 0 1 22 1 0 13 2 1 020 32 0

样例输出
03

来源第五届河南省程序设计大赛上传者rihkddd

import java.util.Scanner;

public class nyoj545Metric_Matrice {

public static void main(String[] args) {
int[][]a;
int n;
Scanner sc = new Scanner(System.in);
int ans=0;
loop:for(int N=sc.nextInt();N-->0;System.out.println(ans)){
n=sc.nextInt();
a=new int

;
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
a[i][j]=sc.nextInt();

for(int i=0;i<n;i++)
for(int j=0;j<n;j++){
if(a[i][i]!=0){
ans=1;continue loop ;
}if(i!=j&&a[i][j]<=0){
ans=2;continue loop;
}if(a[i][j]!=a[j][i]){
ans=3;continue loop;
}
}

for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
for(int k=0;k<n;k++)//该条件不可嵌套在上面代码之中!!!
if((i!=j && j!=k && i!=k)&& ( a[i][j] + a[j][k] < a[i][k] )){
ans=4; continue loop;
}
ans=0;
}
}
}


return做法:

import java.util.Scanner;

public class Main {

private static int[][] array = null;
private static int cases, i, j, n;
private static Scanner in = new Scanner(System.in);

public static void main(String[] args) {
// TODO Auto-generated method stub
cases = in.nextInt();
while (cases-- > 0) {
n = in.nextInt();
array = new int

;
for (i = 0; i < n; ++i) {
for (j = 0; j < n; ++j) {
array[i][j] = in.nextInt();
}
}
System.out.println(solve(array));

}
}

private static int solve(int[][] array) {

for (int i = 0; i < array.length; ++i) {
if (array[i][i] != 0) {
return 1;
}
for (int j = i + 1; j < array[i].length; ++j) {
if (array[i][j] <= 0 || array[j][i] <= 0) {
return 2;
}
if (array[i][j] != array[j][i]) {
return 3;
}
}
}
for (int i = 0; i < array.length; ++i) {
for (int j = 0; j < array[i].length; ++j) {
if (j == i) {
continue;
} else {
for (int k = 0; k < array.length; ++k) {
if (k == i || k == j) {
continue;
} else {
if (array[i][k] + array[k][j] < array[i][j]) {
return 4;
}
}
}
}
}
}

return 0;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: