您的位置:首页 > 其它

反转问题--poj1222

2013-11-28 15:35 288 查看
Language:
Default

EXTENDED LIGHTS OUT

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 5867

Accepted: 3870

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right
and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5.
For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.



The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance,
in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.



Note:

1. It does not matter what order the buttons are pressed.

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.

Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light
is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must
be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input
2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0


Sample Output
PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

思路:状态压缩,枚举第一行状态,判断后面是否可行。
下面是代码:
/*244K,0ms*/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int light[10][10];
int tmp[10][10];
int loop;
int dx[]={-1,1,0,0,0};
int dy[]={0,0,-1,1,0};
//判断这个当前状态
int get(int x,int y)
{
    int c=light[x][y];
    for(int i=0;i<5;i++)
    {
        int tx=x+dx[i];
        int ty=y+dy[i];
        if(tx>=1&&tx<=5&&ty>=1&&ty<=6)
        c+=tmp[tx][ty];
    }
    return c%2;
}
bool calc()
{
    for(int i=2;i<=5;i++)
    {
        for(int j=1;j<=6;j++)
        if(get(i-1,j)!=0)
        tmp[i][j]=1;
    }
    for(int i=1;i<=6;i++)
        if(get(5,i)!=0)
            return false;
    return true;
}
void solve()
{
    //枚举第一行的状态
    for(int i=0;i<(1<<6);i++)
    {
        memset(tmp,0,sizeof(tmp));
        for(int j=0;j<6;j++)
            tmp[1][6-j]=(i>>j)&1;
        if(calc())
            break;

    }
    cout<<"PUZZLE #"<<loop++<<endl;
    for(int i=1;i<=5;i++)
    {
        for(int j=1;j<=6;j++)
            if(j==1)
                cout<<tmp[i][j];
            else
                cout<<' '<<tmp[i][j];
        cout<<endl;
    }
    return;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    cin>>t;
    loop=1;
    while(t--)
    {
        for(int i=1;i<=5;i++)
            for(int j=1;j<=6;j++)
                cin>>light[i][j];
        solve();
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: