您的位置:首页 > 其它

hdu3466Proud Merchants (01背包,以q-p从小到大排序)

2013-11-25 20:47 253 查看
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any
more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output
For each test case, output one integer, indicating maximum value iSea could get.

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3


Sample Output
5
11[code]#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct nn
{
    int use,Q,valu,sub;
}node[505];
int dp[5005],M;
int cmp(nn a,nn b){return a.sub<b.sub;}
void zeroonepack(int use,int Q,int valu)
{
    for(int v=M;v>=Q;v--)
    if(dp[v-use]+valu>dp[v])
    dp[v]=dp[v-use]+valu;
}
int main()
{
    int n;
    while(scanf("%d%d",&n,&M)>0)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&node[i].use,&node[i].Q,&node[i].valu);
            node[i].sub=node[i].Q-node[i].use;
        }
        for(int i=0;i<=M;i++)
        dp[i]=0;
        sort(node,node+n,cmp);//以q-p从小到大排序
        for(int i=0;i<n;i++)
        zeroonepack(node[i].use,node[i].Q,node[i].valu);
        printf("%d\n",dp[M]);
    }
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: