您的位置:首页 > 其它

动态规划1:H - Monkey and Banana(最长非上升子序列)

2013-11-24 20:16 495 查看
Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.



Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.



Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".



Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0




Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


这个开始对题意不是很理解,看了样例也没懂多少……原来是矩形方块可以使用三次,但是转换有六种,因为六种中高一样的时候长和宽可以不一样,所以六种中可以使用三次……先排序好后,再用样似最长上升子序列的动态规划状态方程解决就行了(从底到顶是非最长上升子序列)……如果从顶求的话也就是最长上升子序列了……

#include <iostream>
#include <map>
#include <deque>
#include <queue>
#include <stack>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <map>
#include <set>
using namespace std;
struct abc
{
    int x,y,z;
}s[200];
bool cmp(abc a,abc b)
{
    if(a.x==b.x) return a.y>b.y;
    return a.x>b.x;
}
int main()
{
    int n,k=1;
    while(cin>>n&&n)
    {
        int i,a,b,c,m=0,j,Max,dp[200];
        for(i=0;i<n;i++)
        {
            cin>>a>>b>>c;
            s[m].x=a;s[m].y=b;s[m++].z=c;
            s[m].x=a;s[m].y=c;s[m++].z=b;
            s[m].x=b;s[m].y=a;s[m++].z=c;
            s[m].x=b;s[m].y=c;s[m++].z=a;
            s[m].x=c;s[m].y=a;s[m++].z=b;
            s[m].x=c;s[m].y=b;s[m++].z=a;
        }
        sort(s,s+m,cmp);
        for(i=0;i<m;i++)
            dp[i]=s[i].z;
        Max=dp[0];
        for(i=1;i<m;i++)
        {
            for(j=i-1;j>=0;j--)
                if(s[j].x>s[i].x&&s[j].y>s[i].y)
                    dp[i]=max(dp[i],dp[j]+s[i].z);
            if(Max<dp[i]) Max=dp[i];
        }
        printf("Case %d: maximum height = %d\n",k++,Max);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: