您的位置:首页 > 大数据 > 人工智能

杭电acm 1021 Fibonacci Again

2013-11-24 16:15 471 查看

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31114 Accepted Submission(s): 15079


[align=left]Problem Description[/align]
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

[align=left]Input[/align]
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

[align=left]Output[/align]
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

[align=left]Sample Input[/align]

0
1
2
3
4
5

[align=left]Sample Output[/align]

no
no
yes
no
no
no

#include<stdio.h>

int main()

{
int n,i;
while(scanf("%d",&n)!=EOF)
{
if(n%4==2)
printf("yes\n");
else
printf("no\n");
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: