您的位置:首页 > 其它

POJ 1655 简单树形dp

2013-11-22 15:43 369 查看
Balancing Act

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7872 Accepted: 3220
Description
Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest
T created by deleting that node from T.

For example, consider the tree:



Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these
trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains
two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output
1 2

题意:去点一个点,使得剩下的连通块点数最多的最小。

两个数组维护,搜一遍。

代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string.h>
#include<vector>
using namespace std;
const int  maxn=100000;
int head[maxn],tol;
struct node
{
int next,to;
}edge[maxn];
int num[maxn],dp[maxn],n;
void add(int u,int v)
{
edge[tol].to=v;
edge[tol].next=head[u];
head[u]=tol++;
}
void dfs(int u,int fa)
{
dp[u]=0;num[u]=1;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(v==fa)continue;
dfs(v,u);
num[u]+=num[v];
dp[u]=max(dp[u],num[v]);
}
dp[u]=max(dp[u],n-num[u]);
}
int main()
{
int i,j,k,m,T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
memset(head,-1,sizeof(head));tol=0;
for(i=1;i<n;i++)
{
scanf("%d%d",&j,&k);
add(j,k);
add(k,j);
}
dfs(1,1);
int id=0,ans=n;
for(i=1;i<=n;i++)
if(dp[i]<ans)ans=dp[i],id=i;
printf("%d %d\n",id,ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: