您的位置:首页 > 其它

poj 2828 Buy Tickets(树状数组找部分和为k的第一个位置)

2013-11-21 11:58 344 查看
Buy Tickets

Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 11135Accepted: 5436
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped
the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of
N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next
N lines contain the pairs of values Posi and Vali in the increasing order of
i (1 ≤ i ≤ N). For each i, the ranges and meanings of
Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the
Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value
Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output
77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



题意:n个人排队,给出n行输入,每个输入有两个值pos[i] 和 id[i],pos[i]表示第i个人插队,插到第pos[i]个人的后面,pos[i]的取值为[0,i-1]。要求出当所有人都插完队最后的队列,用id表示。
思路:从后到前开始处理插队,因为迟来的人插队后位置就确定了,早来的人插队时就算出前面有pos[i]+1个空位的位置,将这个人放在这个位置就可以了,而求出这个位置可以用树状数组,求出部分和为pos[i]+1的第一个位置。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <cmath>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll __int64
#define eps 1e-6

using namespace std;

const int INF = 1000000007;
const int maxn = 200005;

int c[maxn], pos[maxn], id[maxn];
int n;
int lowbit(int x)
{
return x & (-x);
}
int find(int k)
{
int mod = 0, ans = 0;
for(int i = 18; i >= 0; i--)
{
ans += (1 << i);
if(ans >= n || mod + c[ans] >= k) ans -= (1 << i);
else mod += c[ans];
}
return ans + 1;
}
void add(int x)
{
for(int i = x; i < maxn; i+= lowbit(i)) c[i]--;
}
int main()
{
int ans[maxn];
while(~scanf("%d", &n))
{
memset(c, 0, sizeof(c));
for(int i = 1; i <= n; i++)
{
c[i] = lowbit(i);
scanf("%d%d", &pos[i], &id[i]);
pos[i]++;
}

for(int i = n; i >= 1; i--)
{
int t = find(pos[i]);
ans[t] = id[i];
add(t);
}
for(int i = 1; i < n; i++) printf("%d ", ans[i]);
printf("%d\n", ans
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: