您的位置:首页 > 其它

A mid-summer night’s dream

2013-11-21 00:29 281 查看
[b]A mid-summer night’s dream[/b]
Input: standard input
Output: standard output

This is year 2200AD. Science has progressed a lot in two hundred years. Two hundred years is mentioned here because this problem is being sent back to 2000AD with the help of time machine. Now it is possible to establish direct connection between man and
computer CPU. People can watch other people’s dream on 3D displayer (That is the monitor today) as if they were watching a movie. One problem in this century is that people have become so dependent on computers that their analytical ability is approaching
zero. Computers can now read problems and solve them automatically. But they can solve only difficult problems. There are no easy problems now. Our chief scientist is in great trouble as he has forgotten the number of his combination lock. For security reasons
computers today cannot solve combination lock related problems. In a mid-summer night the scientist has a dream where he sees a lot of unsigned integer numbers flying around. He records them with the help of his computer, Then he has a clue that if the numbers
are (X1, X2, … , Xn) he will have to find an integer number A (This A is the combination lock code) such that

(|X1-A| + |X2-A| + … … + |Xn-A|) is minimum.

Input

Input will contain several blocks. Each block will start with a number n (0<n<=1000000) indicating how many numbers he saw in the dream. Next there will be n numbers. All the numbers will be less than 65536. The input will be terminated by end of file.

Output

For each set of input there will be one line of output. That line will contain the minimum possible value for A. Next it will contain how many numbers are there in the input that satisfy the property of A (The summation of absolute deviation from A is minimum).
And finally you have to print how many possible different integer values are there for A (these values need not be present in the input). These numbers will be separated by single space.

Sample Input:

2

10

10

4

1

2

2

4

Sample Output:

10 2 1

2 2 1

题意:给你n个数,让你找出一个A使各个数与A的绝对值之差最小,并找出满足在输入数列中这个性质的A的个数,和满足这个性质的所有整数(不需要在输入数列中)。

这个题就是一个求中位数问题。看明白题意就行。

#include <stdio.h>
#include <algorithm>
using namespace std;
int p[1000010];
int main(void){
int n;

while(scanf("%d", &n) != EOF)
{
for(int i = 0; i < n; ++i)
{
scanf("%d", &p[i]);
}
sort(p, p + n);
int l, r;
if(n % 2 == 1)
{
l = n / 2;
r = l;
}
else
{
l = n / 2 - 1;
r = l + 1;
}
int ans = 0;
for(int i = 0; i < n; ++i)
{
if(p[i] >= p[l] && p[i] <= p[r])
ans++;
if(p[i] > p[r])
break;
}
printf("%d %d %d\n", p[l], ans, p[r] - p[l] + 1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: