您的位置:首页 > 其它

UVa 357 Let Me Count The Ways (完全背包)

2013-11-19 08:48 609 查看

357 - Let Me Count The Ways

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=114&page=show_problem&problem=293

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies.
He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The numberm is the number your program computes,
n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4


Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.


思路:dp[i] += dp[i - coin[k]];

注意会超int。

完整代码:

/*0.019s*/

#include<cstdio>
#include<cstring>
const int coin[5] = {1, 5, 10, 25, 50};
const int maxn = 30001;

long long dp[maxn];

int main()
{
	int i, k, n;
	dp[0] = 1;
	for (k = 0; k < 5; ++k)
		for (i = coin[k]; i < maxn; ++i)
			dp[i] += dp[i - coin[k]];
	while (~scanf("%d", &n))
	{
		if (n < 5) printf("There is only 1 way to produce %d cents change.\n", n);
		else printf("There are %lld ways to produce %d cents change.\n", dp
, n);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: