您的位置:首页 > 其它

uva 193 Graph Coloring

2013-11-14 17:01 471 查看
题目地址:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=108&page=show_problem&problem=129

题目描述:



Graph Coloring

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called
optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.



Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers

,

,
and a set of undirected edges denoted by pairs of node numbers

,

.
The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain
the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second
line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6


Sample Output

3
1 4 5


题意:二色着色问题,白色可相邻,黑色不能邻接。

题解:深搜,不需要特地按图的邻接结构去枚举深搜,直接按编号着色,省去了for去找图的邻接点而深搜,不然很有可能会TLE。

代码:

/*
do not confuse the strategy of the DFS and the BFS

this is no in for  DFS

please  compare uva193 withe the uva10001   note the data size of them
*/

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

int m=0,n=0,k=0;
bool Graph[100+5][100+5]={false};//true is connected,begin with 1
int Coloring[100+5]={0};//1 is white 0 is no color -1 is black  so it is also visit array
int BlackNum=0;
int MaxColoring[100+5]={0};
int MaxBlack=0;
int NowColor=0;

/*DFS the graph and color the graph*/
int DFS(int cur)
{
if(NowColor>=n)
{
if(BlackNum>MaxBlack)
{
//printf("success!\n");
MaxBlack=BlackNum;
memcpy(MaxColoring,Coloring,sizeof(Coloring));
}
}
else
{
int i=0;
bool black=true;
bool white=true;//the cur node can be black and white  in the beginning
for(i=1;i<=n;i++)//two for is too long time
{
if(Graph[cur][i]==true)
{
if(Coloring[i]==-1)
{
black=false;
break;
}
}
}
int next=cur+1;
if(!black)
{
//white
NowColor++;
Coloring[cur]=1;
DFS(next);
Coloring[cur]=0;
NowColor--;
}
else
{
//black
BlackNum++;
NowColor++;
Coloring[cur]=-1;
DFS(next);
Coloring[cur]=0;
NowColor--;
BlackNum--;

//white
NowColor++;
Coloring[cur]=1;
DFS(next);
Coloring[cur]=0;
NowColor--;
}
}
return(0);
}

/*for test*/
int test()
{

return(0);
}

/*main process*/
int MainProc()
{
while(scanf("%d",&m)!=EOF&&m>0)
{
while(m--)
{
memset(Graph,false,sizeof(Graph));
memset(Coloring,0,sizeof(Coloring));
memset(MaxColoring,0,sizeof(MaxColoring));
BlackNum=0;
MaxBlack=0;
scanf("%d%d",&n,&k);
int start=0,end=0;
int i=0;
for(i=1;i<=k;i++)
{
scanf("%d%d",&start,&end);
Graph[start][end]=true;
Graph[end][start]=true;
}
NowColor=0;
DFS(1);//DFS the graph and color the graph  AC
printf("%d\n",MaxBlack );
for(i=1;i<=n;i++)
{
if(MaxColoring[i]==-1)
{
printf("%d",i );
break;
}
}
for(i=i+1;i<=n;i++)
{
if(MaxColoring[i]==-1)
{
printf(" %d",i );
}
}

printf("\n");
}
}
return(0);
}

int main(int argc, char const *argv[])
{
/* code */
MainProc();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: