您的位置:首页 > 编程语言 > Go语言

UVALive 3708 Graveyard

2013-11-14 11:03 537 查看
Graveyard

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu
[Submit]  
[Go Back]   [Status]  

Description





Programming contests became so popular in the year 2397 that the governor of New Earck -- the largest human-inhabited planet of the galaxy -- opened a special Alley of Contestant Memories (ACM) at the local
graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.
When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.
Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements
of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance
penalty, so choose the places for newcomers wisely!

Input

The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n -- the number of holographic statues initially located at the ACM, and m --
the number of statues to be added (2

n

1000,
1

m

1000) .
The length of the alley along the park perimeter is exactly 10 000 feet.

Output

For each test case, write to the output a line with a single real number -- the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.



Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Sample Input

2 1
2 3
3 1
10 10


Sample Output

1666.6667
1000.0
1666.6667
0.0


Source

Northeastern Europe & Russian Republic 2006-2007

保持一个点不动,剩下的点移动到距离它最近的位置上去。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

const double eps=1e-8;

int n,m;

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
double ans=0;
for(int i=1;i<n;i++)
{
double temp=(double)i/n*(n+m);
double d1=(double)floor(temp),d2=(double)ceil(temp);
ans+=min(fabs(d1-temp),fabs(d2-temp));
}
printf("%.4lf\n",ans/(n+m)*10000);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM algorithm uva