您的位置:首页 > 其它

POJ1442--Black Box

2013-11-13 22:52 417 查看
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions).
There are two types of transactions:

ADD (x): put element x into Black Box;

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.

Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3312
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
#define maxn 130080
int A[maxn],B[maxn];
struct Node
{
Node * ch[2];
int r,v,s;
bool operator < (const Node & a) const
{
return r < a.r;
}
int cmp(int x) const
{
//if(x == v)	return  -1;
return x < v?0:1;
}
void maintain()
{
s = 1;
if(ch[0] != NULL)	s += ch[0] -> s;
if(ch[1] != NULL)	s += ch[1] -> s;
}
}*root;

void rotate(Node *&o,int d)
{
Node * k = o -> ch[d^1];
o -> ch[d^1] = k -> ch[d];
k -> ch[d] = o;
o -> maintain();
k -> maintain();
o = k;
}

void insert(Node *& o,int x)
{
if(o == NULL)
{
o = new Node();
o -> ch[0] = o -> ch[1] = NULL;
o -> v = x;
o -> r = rand();
o -> s = 1;
}
else
{
int d = o -> cmp(x);
insert(o -> ch[d],x);
if(o -> ch[d] -> r > o -> r)	rotate(o,d^1);
}
o -> maintain();
}

void remove(Node *& o,int x)
{
int d = o -> cmp(x);
if(d == -1)
{
Node * tmp = o;
if(o -> ch[0] == NULL)
{
o = o -> ch[1];
delete tmp;
tmp = NULL;
}
else if(o -> ch[1] == NULL)
{
o = o -> ch[0];
delete tmp;
tmp = NULL;
}
else
{
int d2 = (o -> ch[0] -> r > o -> ch[1] -> r?1:0);
rotate(o,d2);
remove(o -> ch[d2],x);
}
}
else remove(o -> ch[d],x);
if(o != NULL)	o -> maintain();
}

bool find(Node * o,int x)
{
while(o != NULL)
{
int d = o -> cmp(x);
if(d == -1)	return 1;
else o = o -> ch[d];
}
return 0;
}

int Rank(Node * o,int x)
{
int ans = 0;
while(o)
{
if(o -> v == x)
{
if(o -> ch[0])	ans += o -> ch[0] -> s;
return	ans;
}
else if(o -> v > x)
{
o = o -> ch[0];
}
else
{
if(o -> ch[0])	ans += o -> ch[0] -> s;
ans++;
o = o -> ch[1];
}
}
return ans;
}

int Kth(Node *o,int k)//这里是要返回第k小的元素
{

while(k)
{
if(o -> ch[0])
{
if(o -> ch[0] -> s >= k)	o = o -> ch[0];
else if( o -> ch[0] -> s == k-1)	return o -> v;
else k -= o-> ch[0] -> s + 1,o = o -> ch[1];
}
else if( k == 1 )	return  o -> v;
else k--,o = o -> ch[1];
}
/*
int  tmp = 0;
if(o -> ch[0])
{
tmp += o -> ch[0] -> s;
}
if(k == tmp + 1)	return o -> v;
else if(k <= tmp)	return Kth(o -> ch[0],k);
else return Kth(o -> ch[1],k - 1 - tmp);
*/
}

void DeleteTreap(Node *& o)
{
if(o == NULL)	return;
if(o -> ch[0] != NULL)	DeleteTreap(o -> ch[0]);
if(o -> ch[1] != NULL)	DeleteTreap(o -> ch[1]);
delete o;
o = NULL;
}

int main()
{
//	freopen("in.txt","r",stdin);
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
int now = 1;
for(int i = 1;i <= n;i++)	scanf("%d",&A[i]);
for(int i = 1;i <= m;i++)
{
int x;
scanf("%d",&x);
for(;now <= x;now++)
{
insert(root,A[now]);
}
printf("%d\n",Kth(root,i));
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ1422