您的位置:首页 > 其它

HDU 1595

2013-11-12 01:44 302 查看


find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1258 Accepted Submission(s): 445



Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.

Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.

Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write
a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1,
and Marica in city N.

In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10


Sample Output

11
13
27


Author

ailyanlu

Source

HDU 2007-Spring Programming
Contest - Warm Up (1)

Recommend

8600

本题是给你一个无向图,问题在无向图上删去一条边使得从1节点到n节点的最短路变得最长.先对原图求一次最短路,然后枚举删除从1到n路径上的边,再求最短路就可以了。因为删除其他的边对1到n的最短路无影响。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define maxn 1009
#define maxm 1000009
#define INF 1000000000
using namespace std;
int first[maxn];
int v[maxm],next[maxm],w[maxm];
bool inq[maxn];int fa[maxn];
int d[maxn];
int tot,n,m;
void add(int x,int y,int z)
{
v[tot]=y;w[tot]=z;
next[tot]=first[x];
first[x]=tot++;
}
void spfa(int type)
{
queue<int>q;
for(int i=1;i<=n;i++)
d[i]=INF;
d[1]=0;
if(type==2)fa[1]=-1;
q.push(1);
while(!q.empty())
{
int x=q.front();
q.pop();
inq[x]=0;
for(int e=first[x];e!=-1;e=next[e])
{
if(d[v[e]]>d[x]+w[e])
{
d[v[e]]=d[x]+w[e];
if(type==2) fa[v[e]]=x;
if(!inq[v[e]])
{
inq[v[e]]=1;
q.push(v[e]);
}
}
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(first,-1,sizeof(first));tot=0;
for(int i=0;i<m;i++)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
add(x,y,z);
add(y,x,z);
}
spfa(2);
int ans=d
;
int t=n;
while(fa[t]!=-1)
{
int x=fa[t];
int y=t;
int pos;
for(int e=first[x];e!=-1;e=next[e])
if(v[e]==y)
{
pos=e;break;
}
int tmp=w[pos];
w[pos]=INF;
w[pos^1]=INF;
spfa(1);
if(d
<INF)
ans=max(ans,d
);
w[pos]=tmp;
w[pos^1]=tmp;
t=fa[t];
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: