您的位置:首页 > 其它

TOJ 4365 ZOJ 3623 Battle Ships / 完全背包

2013-11-11 15:53 316 查看

Battle Ships

时间限制(普通/Java):1000MS/3000MS 运行内存限制:65536KByte



描述

Battle Ships is a new game which is similar to
Star Craft. In this game, the enemy builds a defense tower, which has
L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes
ti seconds to produce the i-th battle ship and this battle ship can make the tower loss
li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And
producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

输入

There are multiple test cases.

The first line of each case contains two integers N(1 ≤ N ≤ 30) and
L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships,
L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers
t i(1 ≤ t i ≤ 20) and li(1 ≤
li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

输出

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

样例输入

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100


样例输出

2
4
5


http://blog.csdn.net/ten_three/article/details/14487499

#include <stdio.h>
#include <string.h>
struct node
{
	int t;
	int l;
}a[40];
int dp[340];
int max(int x,int y)
{
	return x > y ? x : y;
}
int main()
{
	int n,l,i,j;
	while(scanf("%d %d",&n,&l)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(i = 1;i <= n; i++)
		{
			scanf("%d %d",&a[i].t,&a[i].l);
		}
		for(i = 1;i <= n; i++)
		{
			for(j = 1; j <= 330; j++)
			{
				dp[j + a[i].t] = max(dp[j+a[i].t],dp[j] + j * a[i].l);
			}
		}
		for(i = 1; i <= 330; i++)
			if(dp[i] >= l)
				break;
		printf("%d\n",i);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: