您的位置:首页 > 其它

poj 2387 Til the Cows Come Home

2013-11-08 20:15 239 查看
Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25791 Accepted: 8677
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
Source

USACO 2004 November
简单Dijkstra,靠我只是一个数组开小了10倍,找了我那么久才发现,这再次证明我不是比别人差,只是我比别人粗心,再怎么努力,输在细节方面,好可惜。

#include<iostream>

#include<cstring>

using namespace std;

const int MaxSize=2010;

const int Maxvalue=0x7fffffff;

bool vs[MaxSize];

int value[MaxSize][MaxSize];

int dist[MaxSize];

int n;

int Dijkstra()

{

    int i,j;

    memset(vs, false, sizeof(vs));

    for(i=1; i<=n; ++i)

    {

        dist[i]=value
[i];//所有第一个距离源点的距离;

        vs[i]=false;//并且将所有距离源点第一个的点标记为未访问过;

    }

    value

=0;

    vs
=true;

    dist
=0;

    for(i=1; i<n; ++i)

    {

        int tmp=Maxvalue;

        int pos=n;

        for(j=1; j<=n; ++j)

        {

            if(!vs[j] && dist[j]<tmp)

            {

                pos=j;

                tmp=dist[j];

            }

        }

        vs[pos]=true;

        for(j=1; j<=n; ++j)

        {

            if((!vs[j]) && (value[pos][j]<Maxvalue))

            {

                int newdist=dist[pos]+value[pos][j];

                if(newdist<dist[j])

                {

                    dist[j]=newdist;

                }

            }

        }

    }

    return dist[1];

}

int main()

{

    int T;

    int i,j;

    while(cin>>T>>n)

    {

        for(i=1; i<=n; ++i)

        for(j=1; j<=n; ++j)

            value[i][j]=Maxvalue;//首先要对对于任意两点之间的距离设置成无穷大;

        for(i=0; i<T; ++i)

        {

            int a,b,len;

            cin>>a>>b>>len;

            if(len<value[a][b])

            {

                value[a][b]=len;

                value[b][a]=len;

            }

        }

        cout<<Dijkstra()<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: