您的位置:首页 > 其它

hdu——1170——Balloon Comes!

2013-11-05 18:03 375 查看
Problem Description

The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.

Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.

Is it very easy?

Come on, guy! PLMM will send you a beautiful Balloon right now!

Good Luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know
that A and B are operands and C is an operator.

Output

For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input

4
+ 1 2
- 1 2
* 1 2
/ 1 2


Sample Output

3
-1
2
0.50


#include <iostream>
#include <iomanip>
#include <algorithm>
#include <stdio.h>
using namespace std;
int main()
{
int t;
char s;
int a,b;
while(cin>>t)
{
while(t--)
{
cin>>s;
cin>>a>>b;
if(s=='+')
cout<<a+b<<endl;
else if(s=='-')
cout<<a-b<<endl;
else if(s=='*')
cout<<a*b<<endl;
else if(s=='/')
{
double c=a/(b*1.0);
if(int(c)==c)
cout<<c<<endl;
else
cout<<fixed<<setprecision(2)<<c<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: