您的位置:首页 > 理论基础

POJ 1611 The Suspects (并查集III)

2013-11-03 11:18 309 查看
原题链接:http://poj.org/problem?id=1611

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 19392 Accepted: 9408
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

题目大意:SARS病毒在学校中蔓延。学校的人分为好多个小组。如果一个小组有人患病,则整个小组都患病。0号本身患病(感染源。。。)多组输入输出。 要求患病的人数。

附AC代码:

#include <stdio.h>
#define M 30010
int father[M]={0},rank[M]={0}; //rank[M]标记这个M集合的深度,用来记忆M个节点i与根节点的关系
int sum,n,m;
int Find (int x)
{
if (father[x] != x)
father[x] = Find (father[x]);
return father[x];
}
void Union (int x,int y)
{
x = Find(x);
y = Find(y);
if (x == y) return ;

if (rank[x] > rank[y]) father[y] = x;
else{
father[x] = y;
if (rank[x] == rank[y]) rank[x]++;
}
}
int main(int argc, char *argv[])
{
while (scanf ("%d%d",&n,&m) != EOF){
if (n == 0 && m == 0) break;
else {
int k=0,f=0,i,j,index,sum=1;
for (index =0; index < n; ++index) father[index] = index;
for (index =0; index < m; ++index){
scanf ("%d",&k);
if (k > 0)
scanf ("%d",&f);
for(i =1; i < k; ++i){
scanf ("%d",&j);
Union (f,j);
}
}

for (index =1; index < n; ++index){
if (Find(index) == Find(0)) sum++;
}
printf ("%d\n",sum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息