您的位置:首页 > 其它

POJ 2823Sliding Window(单调队列水题)

2013-11-03 00:45 423 查看
Sliding Window

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 33362 Accepted: 9918
Case Time Limit: 5000MS
Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window
moves rightwards by one position. Following is an example: 

The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37
Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input
8 3
1 3 -1 -3 5 3 6 7

Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7


题目意思就不多说了,直接用单调队列,自己没写输入优化时间还少一点,不过都需要好5s+。单调队列模板题目,纯属娱乐。。预祝明天8086能在南京现场赛上取得好成绩,fighting!!!!

题目地址:Sliding Window

AC代码:

#include<iostream>
#include<cstdio>
using namespace std;

struct node
{
int num;
int i;
}q1[1000006],q2[1000006];

int res1[1000006],res2[1000006];

int getint()
{
int ans=0;
int flag=0;
char ch=getchar();
while(ch<'0'||ch>'9'||ch=='-')
{
if(ch=='-') flag=1;
ch=getchar();
}
while(ch>='0'&&ch<='9')
{
ans=ans*10+(ch-'0');
ch=getchar();
}
if(flag) ans=-ans;
return ans;
}

int main()
{
int n,k,i;
while(cin>>n>>k)
{
int top1,top2,tail1,tail2;
top1=top2=tail1=tail2=0;
int p;
for(i=0;i<n;i++)
{
//p=getint();
scanf("%d",&p);
while(top1<tail1&&q1[tail1-1].num<p) tail1--;
q1[tail1].i=i,q1[tail1++].num=p;
while(i-q1[top1].i>=k) top1++;
while(top2<tail2&&q2[tail2-1].num>p) tail2--;
q2[tail2].i=i,q2[tail2++].num=p;
while(i-q2[top2].i>=k) top2++;
if(i>=k-1) res1[i-k+1]=q1[top1].num,res2[i-k+1]=q2[top2].num;
}

printf("%d",res2[0]);
for(i=1;i<=n-k;i++)
printf(" %d",res2[i]);
printf("\n%d",res1[0]);
for(i=1;i<=n-k;i++)
printf(" %d",res1[i]);
printf("\n");
}
return 0;
}

/*
8 3
-1 2 3 1 3 5 6 7
8 3 1 3 -1 -3 5 3 6 7*/

//5344MS 未读入优化
//7079MS 优化输入之后。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: