您的位置:首页 > 其它

A hard puzzle hdu 1097 数论,规律,循环节

2013-11-02 20:22 246 查看


A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25110    Accepted Submission(s): 8940


Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.

this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

Output

For each test case, you should output the a^b's last digit number.

 

Sample Input

7 66
8 800

 

Sample Output

9
6

 

Author

eddy

 

Recommend

JGShining

我们在做这个题目的时候要清楚一点,就是这个最后一个值是有规律的,所以我们查找循环节的方法来找就是了!!!!

还有就是我本来用java的API想直接做的,但是事实告诉我这样只能超时,唉,看来没有规律是不行的啊!!!!

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{

long long  a,b;
int i,j;
int num[100];
while(cin>>a>>b)
{
a=a%10;
num[0]=1;
num[1]=a;
int flag=1;
long long  sum=a;
int st,en;
for(i=2;i<=100&&flag;i++)
{
sum=sum*a;
sum=sum%10;
num[i]=sum;
for(j=2;j<i;j++)
{
if((num[i]==num[j])&&(num[i-1]==num[j-1]))
{
st=j;
en=i;
// printf("%d%d",st,en);
flag=0;
break;
}
}

}
if(!flag)
{
printf("%d\n",num[st+(b-en)%(en-st)]);

}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  找规律 数论