您的位置:首页 > 其它

【PAT】1070. Mooncake (25)

2013-11-02 19:58 357 查看
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds
of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand
can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the
positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5

Sample Output:
9.45


分析:题目给出各种月饼的最大生产数和总利润。那么可以据此这些月饼的单位利润的高低。进行排序。然后选择单位利润高的即可。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

struct Node{
double ton;  //总生产数
double profit;   //总利润
};

bool cmp(Node a,Node b){
return (a.profit/a.ton) > (b.profit/b.ton);
}

int main()
{
int N,D;
int i;
scanf("%d %d",&N,&D);
vector<Node> vec(N);
for(i=0; i<N; i++){
scanf("%lf",&vec[i].ton);
}
for(i=0; i<N; i++){
scanf("%lf",&vec[i].profit);
}

//按单位利润高低进行排序
sort(vec.begin(),vec.end(),cmp);

double total = 0.0; //生产数
double final = 0.0; //总利润

for(i=0; i<vec.size(); i++){
if( (total+vec[i].ton) <= D ){
total += vec[i].ton;
final += vec[i].profit;
}
else{
final += vec[i].profit * ( (D-total)/(double)vec[i].ton );
total = D;
}
if(total == D){
printf("%.2f\n",final);
return 0;
}
}

printf("%.2f\n",final);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT