您的位置:首页 > 其它

POJ 一 1163 The Triangle

2013-11-01 16:39 471 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 34295Accepted: 20418
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30


找到从顶点到底边某点的一个使得所加和最大的路径。

经典的动态规划题目,使用栈可以解决,但是路径会多次调用,导致超时,想办法保存已经算过的路径即可。

思路是从倒数第二行开始网上遍历,每次检查对应的两个下标大小,将较大的加到现在这个数上。

代码如下:

#include <stdio.h>
int main(void)
{
int rows,i,j;
int a[110][110];

scanf("%d",&rows);
for(i=0;i<rows;i++)
for(j=0;j<=i;j++)
scanf("%d",&a[i][j]);
for(i=rows-2;i>=0;i--)
for(j=0;j<=i;j++)
a[i][j]+=a[i+1][j]>a[i+1][j+1]?a[i+1][j]:a[i+1][j+1];
printf("%d\n",a[0][0]);
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: