您的位置:首页 > 其它

hdu 1241 Oil Deposits

2013-10-30 18:54 232 查看

Oil Deposits

[align=left] [/align]
[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


[align=left]Sample Output[/align]

0
1
2
2


简单深搜:遍历整个字符数组,每次从一个油井开始搜,并把该点标记为‘*’,

然后向8个方向扩展,把与它相邻的油井都标记为‘*’,一直到把相邻油井全搜过为止。

每次搜索把cnt+1就行了!

#include<stdio.h>
#include<string.h>
#define N 105
char map

;
int n,m;
int dir[8][2]={0,1,0,-1,-1,0,1,0,1,1,1,-1,-1,1,-1,-1,};
void dfs(int x,int y)
{
int i,di,dj;
for(i=0;i<8;i++)
{
di=x+dir[i][0];
dj=y+dir[i][1];
if(di>=0&&di<n&&dj>=0&&dj<m&&map[di][dj]=='@')
{
map[di][dj]='*';
dfs(di,dj);
}
}
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m),n||m)
{
for(i=0;i<n;i++)
scanf("%s",map[i]);
int cnt=0;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(map[i][j]=='@')
{
dfs(i,j);
cnt++;
}
}
}
printf("%d\n",cnt);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: