您的位置:首页 > Web前端

hdu 1829 Poj 2492 A Bug's Life

2013-10-29 12:33 471 查看

Problem Description

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following
lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about
the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4


Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


Hint

Huge input,scanf is recommended.

解题思路:

在并查集用一个数组记录元素的根结点的基础上,再用一个数组记录该元素的性别(只用0、1表示就够了)。

就是在并查集的基础上加了个性别判断。

注意理解:

sex[a]=sex[a]^sex[father[a]];

ans=sex[a]^sex[b];

sex[x]=1-sex[a]^sex[b]; /sex[x]=~sex[a]^sex[b];

就可以了。

#include<stdio.h>
#include<string.h>

int  sex[2001],father[2001],ans=1;
void init(int n){
memset(sex,0,sizeof(sex));
for(int i=1;i<=n;i++)
father[i]=i;
}
int find(int a){
int t;
if(a!=father[a]){
t=find(father[a]);
sex[a]=sex[a]^sex[father[a]];
return father[a]=t;
}
return a;
}

int combine(int a,int b){
int x,y;
x=find(a);
y=find(b);
if(x==y)
ans=sex[a]^sex[b];
else{
father[x]=y;
sex[x]=1-sex[a]^sex[b];
}
}
int main(){
int t,i,j,m,n,a,b;
scanf("%d",&t);
for(i=1;i<=t;i++){
ans=1;
printf("Scenario #%d:\n",i);
scanf("%d %d",&n,&m);
init(n);
for(j=0;j<m;j++){
scanf("%d %d",&a,&b);
if(ans){
combine(a,b);
}
}
if(ans)
printf("No suspicious bugs found!\n\n");
else
printf("Suspicious bugs found!\n\n");
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: