您的位置:首页 > 其它

hdu_1009_FatMouse' Trade_201310280910

2013-10-28 09:40 337 查看

FatMouse' Trade

http://acm.hdu.edu.cn/showproblem.php?pid=1009

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 35250 Accepted Submission(s): 11553

[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

[align=left]Sample Output[/align]

13.333
31.500

[align=left]Author[/align]
CHEN, Yue

[align=left]Source[/align]
ZJCPC2004

#include <stdio.h>

typedef struct ST
{
int j;
int f;
double t;
}ST;
ST s[1010];

int cmp(const void *a,const void *b)
{
return (*(ST *)a).t > (*(ST *)b).t ? 1 : -1;
}

int main()
{
int m,n;
while(scanf("%d %d",&m,&n),(m!=-1&&n!=-1))
{
int i,j;
int num;
double sum=0;
for(i=0;i<n;i++)
{
scanf("%d %d",&s[i].j,&s[i].f);
s[i].t = s[i].j*1.0/s[i].f;
}
qsort(s,n,sizeof(s[0]),cmp);
num=m;
for(i=n-1;i>=0;i--)
{
if(num>s[i].f)
{
sum+=s[i].j;
num-=s[i].f;
}
else
{
sum+=s[i].t * num;
num=0;
}
if(num==0)
break;
}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: