您的位置:首页 > 其它

poj 2777 , 线段树

2013-10-27 17:36 134 查看
Count Color

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 32113Accepted: 9642
Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive
integer, so we can evenly divide the board into L segments, and they
are labeled by 1, 2, ... L from left to right, each is 1 centimeter
long. Now we have to color the board - one segment with only one color.
We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red,
green, blue, yellow…), so you may assume that the total number of
different colors T is very small. To make it simple, we express the
names of colors as color 1, color 2, ... color T. At the beginning, the
board was painted in color 1. Now the rest of problem is left to your.

Input

First
line of input contains L (1 <= L <= 100000), T (1 <= T <=
30) and O (1 <= O <= 100000). Here O denotes the number of
operations. Following O lines, each contains "C A B C" or "P A B" (here
A, B, C are integers, and A may be larger than B) as an operation
defined previously.
Output

Ouput results of the output operation in order, each line contains a number.
Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

POJ Monthly--2006.03.26,dodo

线段树

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<set>
#include<queue>
#include<string>
#include<cmath>
#include<fstream>
#include<iomanip>

using namespace std;

#define lson tn<<1, l, m
#define rson tn<<1|1, m, r

#define LL long long
#define MAXN 111111
int col[MAXN<<2], n, m, t;
int todo[MAXN<<2];

void push_up(int tn){ col[tn] = col[tn<<1] | col[tn<<1|1]; }

void push_down(int tn){
if(!todo[tn]) return;
todo[tn<<1] = todo[tn<<1|1] = todo[tn];
col[tn<<1] = col[tn<<1|1] = 1<<todo[tn];
todo[tn] = 0;
}

void build(int tn, int l, int r){
todo[tn] = 0;
if(l+1 == r){
col[tn] = 1 << 1;   return;
}
int m = l + r >> 1;
build(lson);
build(rson);
push_up(tn);
}

void update(int tn, int l, int r, int cl, int cr, int tc){
if(cl<=l && cr>=r){
todo[tn] = tc;      col[tn] = 1<<tc;
return;
}
int m = l + r >> 1;
push_down(tn);
if(cl < m) update(lson, cl, cr, tc);
if(cr > m) update(rson, cl, cr, tc);
push_up(tn);
}

int query(int tn, int l, int r, int cl, int cr){
if(cl<=l && cr>=r) return col[tn];
int m = l + r >> 1;
int ret = 0;
push_down(tn);
if(cl < m) ret |= query(lson, cl, cr);
if(m < cr) ret |= query(rson, cl, cr);
return ret;
}

int main(){
freopen("C:\\Users\\Administrator\\Desktop\\in.txt","r",stdin);
while(scanf(" %d %d %d", &n, &t, &m)==3){
build(1, 1, n+1);
while(m--){
int a, b, c;    char ch;
scanf(" %c %d %d", &ch, &a, &b); if(a > b) swap(a, b);
if(ch == 'C'){
scanf(" %d", &c);
update(1, 1, 1+n, a, b+1, c);
}
else{
int ans = 0, x = query(1, 1, 1+n, a, b+1);
for(int i=t; i>0; i--) if((1<<i) & x)
ans++;
printf("%d\n", ans);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: