您的位置:首页 > 其它

poj——2230——Watchcow(欧拉路+dfs)

2013-10-26 10:23 274 查看
Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to
the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see.
But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4

Sample Output
1
2
3
4
2
1
4
3
2
4
1

题意:Bessie要求从第一个农场巡视到最后一个农场,而且要求每条路要走两遍,并且这两遍必须是不同的方向。
这是一道有向图输出欧拉路径的问题,用dfs回溯,记录点的序号,就可以得到整条欧拉回路的点序列。
#include<stdio.h>
#include<string.h>
#define M 100007
using namespace std;
int vis[M],head[M],path[M];
int n,m,cnt,num;

struct E
{
int to,next;
} edg[M];

void addedge(int a,int b)
{
edg[cnt].to=b;
edg[cnt].next=head[a];
head[a]=cnt++;
}

void dfs(int u)
{
int v;
for(v=head[u]; v!=-1; v=edg[v].next)
{
int next=edg[v].to;
if(!vis[v])
{
vis[v]=1;
dfs(next);
//path[num++]=v;//记录边的路径
}
}
path[num++]=u;//记录点的路径
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
cnt=num=0;
memset(vis,0,sizeof(vis));
memset(head,-1,sizeof(head));
int a,b;
for(int i=1; i<=m; i++)
{
scanf("%d%d",&a,&b);
addedge(a,b);
addedge(b,a);
}
dfs(1);
for(int i=0; i<num; i++)
printf("%d\n",path[i]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: