您的位置:首页 > 其它

二分搜索--poj3104

2013-10-25 22:05 190 查看
Language:
Default

Drying

Time Limit: 2000MS

Memory Limit: 65536K

Total Submissions: 7269

Accepted: 1873

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at
a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only
if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water,
the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤
109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5


Sample Output
sample output #1
3

sample output #2
2

刚上来想的是用优先队列,觉得有点麻烦,然后二分,不知道咋么判断是否符合条件,然后看了大神的公式。。。
直接二分答案,然后判断答案的正确性。
假设当前二分的答案为 t,那么:
对于ai <= t的衣服,显然让它们自然风干就可以了。
对于ai > t的衣服,我们需要知道该衣服最少用多少次烘干机。
设该衣服用了x1分钟风干,用了x2分钟烘干机。
那么有 x1 + x2 = t 和 ai <= x1 + x2 * k,联立两式可得 x2 >= (ai - t) / (k - 1),即最少使用次数为[(ai - t) / (k - 1)] 的最小上界。
最后,判断一下总使用次数是否少于 t 即可。

下面是代码:
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
const int INF=2000000000;
int N,M;
int a[100010];
bool can(LL mid)
{
    LL sum=0;
    for(int i=0;i<N;i++)
    {
        if(a[i]<=mid)
            continue;
        sum+=(a[i]-mid+M-2)/(M-1);
    }
    return sum<=mid;
}
int main()
{
    while(cin>>N)
    {
        int max1=0;
        for(int i=0;i<N;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>max1)
                max1=a[i];
        }
        cin>>M;
        if(M<=1)
        {
            cout<<max1<<endl;
            continue;
        }
        LL l=0,r=INF,mid;
        while(l<r)
        {
            mid=(l+r)>>1;
            if(can(mid))
                r=mid;
            else l=mid+1;
        }
        cout<<l<<endl;
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: