您的位置:首页 > 编程语言

I Think I Need a Houseboat

2013-10-24 22:04 274 查看
Time Limit: 1.0 Seconds   Memory Limit: 65536K
Total Runs: 3862   Accepted Runs: 1367


Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles
each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The
semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)



Input Format

The first line of input will be a positive integer indicating how many data sets will be included (N). 

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output Format

For each data set, a single line of output should appear. This line should take the form of: 

"Property N: This property will begin eroding in year Z."

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. 

After the last data set, this should print out "END OF OUTPUT."
Notes: 

No property will appear exactly on the semicircle boundary: it will either be inside or outside.

This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

All locations are given in miles.

Sample Input

2
1.0 1.0
25.0 0.0


Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.


题意概述:其实是一个计算面积的问题。在平面上做平面直角坐标系,x轴将平面分为上下两部分,给定上半平面上一个点(包括X轴上的点),以坐标原点为圆心做半圆,其实时刻半圆面积为0,半圆面积每次增加50,问需要增加多少次才能使给定点位于圆内。水题。。。

解题思路:直接计算以坐标原点为圆心,给定点与坐标原点之间的距离为半径的半圆的面积。将求得的面积直接除以50,将所得的商加1  即可得到需要的次数。

源代码:

#include<iostream>

#define PI  3.1415    //宏定义

using namespace std;

int main()

{

    int N,year;

    double X,Y,Area;

    cin>>N;

    for(int i=1;i<=N;++i)

    {

         cin>>X>>Y;

         Area=PI*(X*X+Y*Y)/2;

         year=int(Area/50);

         cout<<"Property "<<i<<": This property will begin eroding in year "<<year+1<<"."<<endl;

         if(i==N)cout<<"END OF OUTPUT."<<endl;

    }

    return 0;

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM编程 源代码