您的位置:首页 > 运维架构

HDU 1011 (ZOJ 2111)Starship Troopers 树形背包

2013-10-22 22:47 369 查看
点击打开链接


Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8524    Accepted Submission(s): 2374


Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

 

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

 

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

 

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

 

Sample Output

50
7

 

Author

XU, Chuan

 

Source

ZJCPC2004

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1561 1203 2955 2415 1059 

题意是说有n个洞形成一棵树,你有m个士兵,每个洞都有一定数量的虫子和一定概率的首脑。每个士兵可以攻击20只虫子。而且想要攻击下面的洞的虫子,必须要攻击上层的虫子,问你花费这m个士兵,最多可以得到多少概率的首脑。
树形dp,每个洞的虫子代表空间,首脑代表价值,那么这就转换成了背包问题,在树上进行背包运算。

#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
#define M 107
using namespace std;
vector<int> e[M];
int w[M],v[M],dp[M][M];
bool vis[M];
int n,m;

void dfs(int p)
{
int tmp=(w[p]+19)/20;
for(int i=tmp;i<=m;i++)
dp[p][i]=v[p];
vis[p]=true;
for(int i=0;i<e[p].size();i++)
{
int to=e[p][i];
if(vis[to])continue;
dfs(to);
for(int j=m;j>=tmp;j--)//背包
{
for(int k=1;k<=(j-tmp);k++)
dp[p][j]=max(dp[p][j],dp[p][j-k]+dp[to][k]);
}
}
}

int main()
{
while(scanf("%d%d",&n,&m),n!=-1||m!=-1)
{
for(int i=0;i<=n;i++)
e[i].clear();
memset(vis,false,sizeof(vis));
memset(dp,0,sizeof(dp));
int a,b;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&w[i],&v[i]);
}
for(int i=1;i<n;i++)
{
scanf("%d%d",&a,&b);
e[a].push_back(b);
e[b].push_back(a);
}

if(m==0)
{
printf("0\n");
continue;
}
dfs(1);
printf("%d\n",dp[1][m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: