您的位置:首页 > 其它

poj 2499 Binary Tree(超简单的二叉树)

2013-10-22 22:17 393 查看
Binary Tree

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5628 Accepted: 2623
Description

Background 

Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
The root contains the pair (1, 1). 

If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem 

Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right
child?
Input

The first line contains the number of scenarios. 

Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent 

a node (i, j). You can assume that this is a valid node in the binary tree described above.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and
r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
Sample Input
3
42 1
3 4
17 73

Sample Output
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source

TUD Programming Contest 2005 (Training Session), Darmstadt, Germany

呵呵,做题就应该好好读题。坑死我了。

AC掉了的代码:

#include<stdio.h>

int main()

{

    int i=0;

    int N;

    scanf("%d",&N);

    while(i<N)

    {

        int a,b;

        int left=0,right=0;

        scanf("%d%d",&a,&b);

        while(a!=1 || b!=1)

        {

            if(a>b)

            {

                left+=(a-1)/b;

                a=(a-1)%b+1;

            }

            else

            {

                right+=(b-1)/a;

                b=(b-1)%a+1;

            }

        }

        printf("Scenario #%d:\n%d %d\n\n",++i,left,right);

    }

    return 0;

}

[Submit]   [Go
Back]   [Status]   [Discuss]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: