您的位置:首页 > 运维架构 > Linux

Linux下高并发socket最大连接数所受的各种限制【转】

2013-10-22 17:14 501 查看


帧中继交换机FRS配置:
Current configuration : 1686 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
frame-relay switching
!
!
!
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
serial restart-delay 0
clock rate 2016000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/3 102
!
interface Serial0/1
no ip address
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
serial restart-delay 0
clock rate 2016000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/3 103
!
interface Serial0/2
no ip address
encapsulation frame-relay
shutdown
serial restart-delay 0
clock rate 2016000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0 201
frame-relay route 103 interface Serial0/1 301
!
interface Serial0/3
no ip address
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
ip ospf network point-to-multipoint
serial restart-delay 0
clock rate 2016000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0 201
frame-relay route 103 interface Serial0/1 301
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
ip http server
!

!
control-plane
!

!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!

远程R的配置(R4):

R4#sh run
Building configuration...
Current configuration : 1386 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!

!
!

!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.1 102 broadcast
frame-relay map ip 192.168.1.2 103 broadcast
frame-relay map ip 192.168.1.3 102
no frame-relay inverse-arp
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router ospf 110
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip http server
!

!
!
!
control-plane
!

line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

本地R2\R3配置:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.2 201 broadcast
frame-relay map ip 192.168.1.3 201 broadcast
no frame-relay inverse-arp
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
ip address 192.168.2.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router ospf 110
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip http server

R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/1
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.1 301 broadcast
frame-relay map ip 192.168.1.2 301
frame-relay map ip 192.168.1.3 301 broadcast
no frame-relay inverse-arp
!
interface Serial0/2
ip address 192.168.2.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router ospf 110
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip http server

上面是4个路由器/交换机的sh run。
在做这个实验的时候总是不断的出现错误,还是自身对FR(NBMA)的只是不够扎实,比如忘记封装、写FR-route的时候会忘记进/出编号、写FR-MAP的时候忘记打上BOARDCAST、忘记设置NBMA的类型:point-to-multipoint,这些都是一些小的地方,但是却很致命,因为在这些小错误上面浪费了大量的时间。

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
O 2.2.2.0 [110/65] via 192.168.1.1, 00:44:03, Serial0/3
3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/129] via 192.168.1.1, 00:44:03, Serial0/3
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
O 192.168.1.1/32 [110/64] via 192.168.1.1, 00:44:03, Serial0/3
C 192.168.1.0/24 is directly connected, Serial0/3
O 192.168.2.0/24 [110/128] via 192.168.1.1, 00:44:03, Serial0/3
R4#
可见,在远程R4上已经通过FR学习到了本地R2\R3的路由,FR搭建有效。

FR相关命令:
encapsulation frame-relay

no ip route-cache

clock rate 2016000

frame-relay intf-type dce

frame-relay route 201 interface Serial0/3 102

ip ospf network point-to-multipoint

frame-relay map ip 192.168.1.1 102 broadcast

frame-relay map ip 192.168.1.2 103 broadcast

frame-relay map ip 192.168.1.3 102(本地PING)

no frame-relay inverse-arp本文出自 “Young’s_CCIE” 博客,转载请与作者联系!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: