您的位置:首页 > 编程语言 > C语言/C++

ZOJ-1151 Word Reversal,栈的解法

2013-10-21 22:53 405 查看
Word Reversal

Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

For each list of words, output a line with each word reversed without changing   the order of the words.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed   by N input blocks. Each input block is in the format indicated in the problem   description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between   output blocks.

Input

You will be given a number of test cases. The first line contains a positive   integer indicating the number of cases to follow. Each case is given on a line   containing a list of words separated by one space, and each word contains only   uppercase and lowercase
letters.

Output

For each test case, print the output on one line.

Sample Input

1

3

  I am happy today

  To be or not to be

  I want to win the practice contest

Sample Output

I ma yppah yadot

  oT eb ro ton ot eb

  I tnaw ot niw eht ecitcarp tsetnoc

******栈法求解******************************************************************************************************************

#include<stdio.h>  

#include<algorithm>  

#include<iostream>  

#include<stack>  

#include<string.h>  

using namespace std;  

stack<char>z;  

int main()  

{  

    int k;  

    int n;  

    char a[999];  

    scanf("%d",&k);  

    while(k--)  

    {  

        scanf("%d",&n);  

        getchar();  

        while(n--)  

        {  

            gets(a);  

            int l=strlen(a);  

            int i=0;  

            while(1)  

            {  

                while(a[i]!=' '&&i<l)  

                {  

                    z.push(a[i]);  

                    i++;  

                }  

                while(!z.empty())  

                {  

                    printf("%c",z.top());  

                    z.pop();  

                }  

                if(i!=l)  

                {  

                    printf(" ");  

                    i++;  

                }  

                else break;  

            }  

            printf("\n");  

        }  

        if(k)  

            printf("\n");  

    }  

    return 0;  

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C语言 ACM