您的位置:首页 > 其它

hdu 1712 分组背包

2013-10-20 14:51 267 查看

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3124 Accepted Submission(s): 1623


[align=left]Problem Description[/align]
ACboy
has N courses this term, and he plans to spend at most M days on
study.Of course,the profit he will gain from different course depending
on the days he spend on it.How to arrange the M days for the N courses
to maximize the profit?

[align=left]Input[/align]
The
input consists of multiple data sets. A data set starts with a line
containing two positive integers N and M, N is the number of courses, M
is the days ACboy has.
Next follow a matrix A[i][j],
(1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy
spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

[align=left]Sample Input[/align]

2 2

1 2

1 3

2 2
2 1
2 1

2 3

3 2 1
3 2 1

0 0

[align=left]Sample Output[/align]

3
4

6
#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
int n,m,p[110][110],s[110][110];
int i,j,k,v;
while(cin>>n>>m)
{
if(n==0&&m==0)
break;
for(i=1; i<=n; i++)
for(j=1; j<=m; j++)
scanf("%d",&p[i][j]);
memset(s,0,sizeof(s));
for(i=1; i<=n; i++)
{
for(j=m; j>=0; j--)
for(k=j; k>=1; k--)
{
s[i][j]=max(s[i][j],s[i-1][j]);//开始没有加这一句,一直wa
s[i][j]=max(s[i][j],s[i-1][j-k]+p[i][k]);
}

}
int mm=0;
for(i=1; i<=m; i++)
if(s
[i]>mm)
mm=s
[i];
cout<<mm<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: