您的位置:首页 > 其它

Ice_cream’s world III--2122

2013-10-19 09:11 204 查看

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 576 Accepted Submission(s): 185

[align=left]Problem Description[/align]
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.

[align=left]Input[/align]
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.

[align=left]Output[/align]
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.

[align=left]Sample Input[/align]

2 1
0 1
10

4 0

[align=left]Sample Output[/align]

10

impossible

思路:prime,考虑重边!!!
AC代码:

#include<stdio.h>
#include<string.h>
int map[1001][1001],dist[1001];
int vis[1001],n;
void init1()
{
int i,j;
for(i = 0;i < n;i ++)
{
for(j = 0;j < n;j ++)
{
if(i != j)
map[i][j] = 1 << 30;
}
}
}
void init2()
{
int i;
memset(vis,0,sizeof(vis));
for(i = 0;i < n;i ++)
dist[i] = map[0][i];
}
int main()
{
int m,i,j,k,cnt;
int min,len,sum,a,b;
while(~scanf("%d%d",&n,&m))
{
init1();
sum = cnt = 0;
while(m--)
{
scanf("%d%d%d",&a,&b,&len);
if(len < map[a][b])
map[a][b] = map[b][a] = len;
}
init2();
vis[0] = 1;
for(i = 0;i < n;i ++)
{
min = 1 << 30;
for(j = 0;j < n;j ++)
{
if(!vis[j] && min > dist[j])
{
min = dist[j];
k = j;
}
}
vis[k] = 1;
if(min != 1 << 30)
{
cnt++;
sum += min;
}
for(j = 0;j < n;j ++)
{
if(!vis[j] && dist[j] > map[k][j])
dist[j] = map[k][j];
}
}
if(cnt == n-1)
printf("%d\n\n",sum);
else
printf("impossible\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: