您的位置:首页 > 其它

POJ 2409 Let it Bead

2013-10-18 21:26 260 查看
[align=center]Let it Bead[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4072 Accepted: 2667
Description
"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets.
However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not
be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate
the number of different bracelets that can be made.
Input
Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical
difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output


For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.
Sample Input
1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output
1
2
3
5
8
13
21

Source
Ulm Local 2000
  polya       或Burnside引理

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#define N 40
using namespace std;
__int64 a
;
int main()
{
//freopen("data.in","r",stdin);
int gcd(int x,int y);
int n,m;
while(scanf("%d %d",&m,&n)!=EOF)
{
if(n==0&&m==0)
{
break;
}
if(n==0)
{
printf("0\n");
continue;
}
a[1] = m;
for(int i=2;i<=n;i++)
{
a[i]=a[i-1]*m;
}
__int64 res1=0;
for(int i=1;i<=n;i++)
{
res1+=(a[gcd(i,n)]);
}
__int64 res2=0;
if(n%2)
{
res2 +=(n*a[(n+1)/2]);
}else
{
res2+=((n/2)*(a[(n/2)+1]+a[n/2]));
}
cout<<(res1+res2)/2/n<<endl;
}
return 0;
}
int gcd(int x,int y)
{
return y==0 ? x:gcd(y,x%y);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: