您的位置:首页 > 其它

1067. Sort with Swap(0,*)

2013-10-16 16:55 441 查看
Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following
way:

Swap(0, 1) => {4, 1, 2, 0, 3}

Swap(0, 3) => {4, 1, 2, 3, 0}

Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10 3 5 7 2 6 4 9 0 8 1

Sample Output:
9
#include <iostream>
#include <string>
#include <map>
#include <algorithm>
#include <vector>
using namespace std;
int main()
{
int n;
cin >> n;
int* arr = new int
;
bool* flag = new bool
;
int count(0);
int circlecount(0);
for(int i = 0;i < n;++ i)
{
cin >> arr[i];
flag[i] = false;
}
for(int i = 0;i < n;++ i)
{
if(flag[i] == true)
continue;
if(arr[i] == i)
{
flag[i] = true;
}
else
{
++ circlecount;
int idx = i;
int value = arr[idx];
while(value != i)
{
idx = value;
value = arr[idx];
flag[idx] = true;
++ count;
}
}
}
if(arr[0] != 0)
cout << count + 2 * (circlecount - 1);
else
cout << count + 2 * circlecount;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: