您的位置:首页 > 其它

HDU 1045Fire Net(暴力DFS)

2013-10-15 18:53 447 查看


Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5191    Accepted Submission(s): 2918


Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

 

Sample Output

5
1
5
2
4

 

题目大意:点表示可以放碉堡的位置,一行一列只能有一个碉堡,不过,X是挡的东西,所以两个碉堡之间有X就可以放!问你最多可以放多少个。

       解题思路:题目的规模n很小,直接采取暴力DFS,详解见代码。

       题目地址:Fire Net

AC代码:

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int n,res;
char a[5][5];

int ok(int x,int y)
{
int i;
for(i=y-1;i>=0;i--)   //看同一行的
{
if(a[x][i]=='X') break;
if(a[x][i]=='#') return 0;
}
for(i=x-1;i>=0;i--)   //看同一列的
{
if(a[i][y]=='X') return 1;
if(a[i][y]=='#') return 0;
}
return 1;
}

void dfs(int p,int num)
{
int x,y;
if(p==n*n)   //已经拜访到了最后的点
{
if(num>res) res=num;
return;
}
x=p/n,y=p%n;
if(a[x][y]=='.'&&ok(x,y))
{
a[x][y]='#';
dfs(p+1,num+1);
a[x][y]='.';
}
dfs(p+1,num);
}

int main()
{
int i;
while(scanf("%d",&n)&&n)
{
res=0;
for(i=0;i<n;i++)
scanf("%s",a[i]);
dfs(0,0);
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: